What is jdk is needed for appzard

what is jdk is needed for appzard and please give me the link

2 Likes

it is called java jdk you can download it from -
https://www.oracle.com/java/technologies/javase/javase-jdk8-downloads.html

3 Likes

but what an i dowalod this Java SE Development Kit 8u301 Demos and Samples Downloads or this Java SE Development Kit 8u301

1 Like

You need java 8 to use ApoZard.

You need this, Download this .exe file & run.

1 Like

ok
but when i m unning appzard doctor i got this eroor
[email protected] MINGW64 ~/OneDrive/Desktop
$ appzard doctor
Making sure all setup…
Checking Java is installed…
Unhandled exception:
RangeError (index): Invalid value: Only valid value is 0: 1
#0 _GrowableList.[] (dart:core-patch/growable_array.dart:254)
#1 Util.getJavaVersion (file:///d:/a/appzardofflinesources/appzardofflinesources/lib/util.dart:111)

#2 main (file:///d:/a/appzardofflinesources/appzardofflinesources/lib/appzard.dart:72)

1 Like

@Vyankteshgurav Can you please try appzard start -d and show us the result?

i got this message
[email protected] MINGW64 ~/OneDrive/Desktop
$ appzard start -d
Starting Appzard local instance…
$ C:\Users\Aarush\AppData\Roaming\appzard\deps\appengine\bin\dev_appserver.cmd --port=8888 --address=0.0.0.0 C:\Users\Aarush\AppData\Roaming\appzard\deps\build\war

1 Like

You have special character(@) in your username([email protected]). Remove @ from your Username.

no my username is aarush and my computer name is guru

1 Like

Hello, please run the following commands and post the output:

java -version
javac -version
1 Like

when i run this two command i dident get any result

1 Like

@Vyankteshgurav Show us a Preview or run in cmd.