builder not run

Executing [C:\Program Files\Java\jdk-17.0.1\bin\java, -Dfile.encoding=UTF-8, -classpath, C:\Users\Administrator\AppData\Roaming\appzard\appengine\bin..\lib\appengine-tools-api.jar, com.google.appengine.tools.development.DevAppServerMain, --property=kickstart.user.dir=C:\Program Files (x86)\Appzard Offline, --no_java_agent, --port=8888, --address=0.0.0.0, C:\Users\Administrator\AppData\Roaming\appzard\build\build\war]


There is a new version of the SDK available.

Latest SDK:
Release: 1.9.98
Timestamp: Tue Jul 12 12:27:02 PKT 2022
API versions: [1.0]


Your SDK:
Release: 1.9.76
Timestamp: Thu Jan 01 05:00:00 PKT 1970
API versions: [1.0]


Please visit Install an SDK for App Engine  |  App Engine Documentation  |  Google Cloud for the latest SDK.


java.lang.RuntimeException: Unable to create a DevAppServer
at com.google.appengine.tools.development.DevAppServerFactory.doCreateDevAppServer(DevAppServerFactory.java:369)
at com.google.appengine.tools.development.DevAppServerFactory.createDevAppServer(DevAppServerFactory.java:301)
at com.google.appengine.tools.development.DevAppServerMain$StartAction.apply(DevAppServerMain.java:383)
at com.google.appengine.tools.util.Parser$ParseResult.applyArgs(Parser.java:45)
at com.google.appengine.tools.development.DevAppServerMain.run(DevAppServerMain.java:257)
at com.google.appengine.tools.development.DevAppServerMain.main(DevAppServerMain.java:248)
Caused by: java.lang.ExceptionInInitializerError
at com.google.appengine.tools.development.DevAppServerImpl.(DevAppServerImpl.java:125)
at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:77)
at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:499)
at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:480)
at com.google.appengine.tools.development.DevAppServerFactory.doCreateDevAppServer(DevAppServerFactory.java:354)
… 5 more
Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make static java.net.URLStreamHandler java.net.URL.getURLStreamHandler(java.lang.String) accessible: module java.base does not “opens java.net” to unnamed module @7db12bb6
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:354)
at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:297)
at java.base/java.lang.reflect.Method.checkCanSetAccessible(Method.java:199)
at java.base/java.lang.reflect.Method.setAccessible(Method.java:193)
at com.google.appengine.tools.development.StreamHandlerFactory.(StreamHandlerFactory.java:41)
… 12 more

Press window + R and type “cmd”. Press Enter. Now, type java -version and send me the results

Also, Make sure you installed PostgreSQL correctly

java version “17.0.1” 2021-10-19 LTS
Java™ SE Runtime Environment (build 17.0.1+12-LTS-39)
Java HotSpot™ 64-Bit Server VM (build 17.0.1+12-LTS-39, mixed mode, sharing)

PostgreSQL not install

You need to install Java 8(You have installed Java 17)

You need to install it

See this guide - How to install Appzard offline GUI

Hello @alimehar,
Welcome to :appzard:ppzard!
Please follow the instructions of @AryanGupta

1 Like