Appzard offline doesn't build APKs : Connection Refused

1
2
hello sir app not building says connection refused i am on latest version but still hgot this error

1 Like

Hello,
The buildserver doesn’t seem to start properly on your device, can you please run appzard start -d and post the full output?

3 Likes



sir here it is

1 Like

Thank you, your device is picking a lower maximum heap memory for java that overrides the value we set, please remove the _JAVA_OPTIONS variable from your windows environment variables, or set it to -Xmx3000m?

1 Like

Actually it will be so much laggy for low end users like me, instead, he can use -Xmx2048m that will be working + non laggy method

Regards

1 Like

The builds takes typically much memory to run without getting out off memory, i think the specified memory could be decreased, we will change it in the next update.

2 Likes

@KAKA Were you able to sort out issue ?

1 Like

I haven’t _JAVA_OPTIONS variable in my windows environment variables, but I got the same problem.

1 Like

Welcome @DevYb,
May i please know how much memory ( RAM ) does you computer have? Seems it’s failing to allocate 3GB ram for the buildserver.

2 Likes

Thank you, @MohamedTamer!

My pc has 8GB of ram memory.

2 Likes

Thanks, Can you please check from the Windows Task Manager, what’s the amount of free memory, you need at least 3GB ram free in order for the buildserver to run.

2 Likes


I have more than 3GB of free RAM, which I think is enough, but I’m still getting the same error (Could not reserve enough space for 3072000KB object heap).

1 Like

You have exactly 3GB ram available, the Java VM typically would need a few more megabytes to reverse, we will reduce the maximum java heap size in the next update , so it doesn’t require 3GB ram, but you could meanwhile close programs taking a large amount of space to free up some memory for the buildserver.

2 Likes

Thanks for your answer!

Actually, I have almost 5GB as you can see in the screenshot below.

I have already tried to close every program running, but I got same error.

1 Like

So @DevYb Can you try by adding _JAVA_OPTIONS

1 Like

Problem solved!
I was using 32-bit JVM, so I downloaded the 64-bit JVM, and now it’s working.
Thanks to all! @MuhammadMansuri , @MohamedTamer .

2 Likes

I also got this error how too fix this?

1 Like